Command Injection Affecting get-npm-package-version package, versions <1.0.7


0.0
high

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-GETNPMPACKAGEVERSION-1050390
  • published 20 Jan 2021
  • disclosed 11 Dec 2020
  • credit JHU System Security Lab

How to fix?

Upgrade get-npm-package-version to version 1.0.7 or higher.

Overview

Affected versions of this package are vulnerable to Command Injection via main function in index.js.

PoC

var a = require("get-npm-package-version");
a("& touch JHU");