Insufficient Session Expiration Affecting ghost package, versions <6.34.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.19% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Insufficient Session Expiration vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-GHOST-21693946
  • published24 Oct 2026
  • disclosed1 Oct 2026
  • creditUnknown

Introduced: 1 Oct 2026

NewCVE-2026-103279  (opens in a new tab)
CWE-613  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.34.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Insufficient Session Expiration via the password change and password reset endpoints, which destroy all other active sessions for the user but preserve the originating session's session_id unchanged. An attacker who has obtained a copy of the pre-change session cookie can continue to use it after the victim changes or resets their password, because the cookie value is never rotated. The fix introduces rotateAndAssignVerifiedUserToSession, which calls req.session.regenerate() on both endpoints so the originating browser retains its login with a fresh session_id, invalidating any cloned or stolen copy of the old cookie.

References

CVSS Base Scores

version 4.0
version 3.1