Incorrect Authorization Affecting ghost package, versions >=0.5.0 <6.64.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.19% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-GHOST-21693955
  • published24 Oct 2026
  • disclosed7 Oct 2026
  • creditSantosh Kumar Puppala, nhattanhh

Introduced: 7 Oct 2026

NewCVE-2026-104412  (opens in a new tab)
CVE-2026-105678  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.64.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Incorrect Authorization in the user role edit validation logic in ghost/core/core/server/models/user.js, where the authorization check for role assignment is skipped when a user edits another user's profile while leaving the role field unchanged. An authenticated Editor can promote an Author to Editor by submitting a role assignment request that echoes back the target user's existing role, bypassing the role hierarchy enforcement that would otherwise prevent this escalation.

CVSS Base Scores

version 4.0
version 3.1