Unsafe Dependency Resolution Affecting ghost package, versions >=6.10.3 <6.64.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.65% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Unsafe Dependency Resolution vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-GHOST-21693961
  • published24 Oct 2026
  • disclosed7 Oct 2026
  • creditUnknown

Introduced: 7 Oct 2026

NewCVE-2026-104418  (opens in a new tab)
CVE-2026-105677  (opens in a new tab)
CWE-22  (opens in a new tab)
CWE-829  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.64.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Unsafe Dependency Resolution via the _readTranslationsFile method in the i18n theme engine, where a locale value is used to construct a file path without first validating that the resolved path remains within the translations directory. An authenticated administrator can supply a locale string containing path traversal sequences (e.g. ../../) to read arbitrary files from the server filesystem.

CVSS Base Scores

version 4.0
version 3.1