Incomplete List of Disallowed Inputs Affecting ghost package, versions >=2.5.0 <6.64.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.28% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-GHOST-21693964
  • published24 Oct 2026
  • disclosed7 Oct 2026
  • creditnhattanhh

Introduced: 7 Oct 2026

NewCVE-2026-104414  (opens in a new tab)
CVE-2026-105650  (opens in a new tab)
CWE-184  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.64.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Incomplete List of Disallowed Inputs via the oEmbed service (ghost/core/core/server/services/oembed/oembed-service.js) when handling photo-type oEmbed responses from arbitrary, self-declared oEmbed endpoints. Provider-supplied HTML from a photo response is stored in the post's Lexical payload and rendered into the admin editor preview via srcdoc and into public themes and emails via innerHTML, allowing an attacker who controls an oEmbed endpoint to inject arbitrary HTML and execute scripts in the context of a visitor's browser.

CVSS Base Scores

version 4.0
version 3.1