Server-side Request Forgery (SSRF) Affecting ghost package, versions >=6.54.1 <6.65.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.24% (15th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-GHOST-21693970
  • published24 Oct 2026
  • disclosed7 Oct 2026
  • creditnhattanhh

Introduced: 7 Oct 2026

NewCVE-2026-105647  (opens in a new tab)
CWE-367  (opens in a new tab)
CWE-918  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.65.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Server-side Request Forgery (SSRF) via the favicon lookup in the OEmbed service, where the metascraper-logo-favicon dependency's default resolver uses reachable-url, which bundles got v11 and bypasses the dnsLookup hook that externalRequest installs to validate resolved IP addresses at connection time. An attacker can exploit this DNS rebinding gap to cause the server to issue requests to internal network resources that would otherwise be blocked by the IP validation logic.

CVSS Base Scores

version 4.0
version 3.1