Arbitrary Code Injection Affecting ghost package, versions >=6.56.0 <6.67.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.27% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-GHOST-21693972
  • published24 Oct 2026
  • disclosed7 Oct 2026
  • creditrafabd1

Introduced: 7 Oct 2026

NewCVE-2026-105642  (opens in a new tab)
CWE-1395  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.67.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Arbitrary Code Injection via a vulnerability in the SVG handling of an image processing library bundled with Ghost. When a staff user (including a Contributor) creates a bookmark card pointing to an attacker-controlled website, the server fetches and processes attacker-supplied SVG content, resulting in arbitrary commands being executed on the Ghost server.

References

CVSS Base Scores

version 4.0
version 3.1