Incorrect Authorization Affecting ghost package, versions >=5.125.1 <6.57.1


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.17% (6th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-GHOST-21693982
  • published24 Oct 2026
  • disclosed1 Oct 2026
  • creditUnknown

Introduced: 1 Oct 2026

NewCVE-2026-103284  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.57.1 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Incorrect Authorization via the Admin Feedback endpoint, which lacks proper authorization checks for staff-level users. An authenticated attacker with staff privileges can query the feedback endpoint to retrieve sensitive member information they are not authorized to access.

References

CVSS Base Scores

version 4.0
version 3.1