Insertion of Sensitive Information Into Sent Data Affecting ghost package, versions >=3.23.0 <6.23.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.16% (5th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-GHOST-21693983
  • published24 Oct 2026
  • disclosed1 Oct 2026
  • creditUnknown

Introduced: 1 Oct 2026

NewCVE-2026-103281  (opens in a new tab)
CWE-201  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.23.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Insertion of Sensitive Information Into Sent Data via the Admin API, which returns API keys to authenticated low-privilege staff users who should not have access to them. These keys are intended to be restricted to higher-privileged users, but insufficient access controls allow any staff-level authenticated user to read them through standard Admin API responses.

References

CVSS Base Scores

version 4.0
version 3.1