Incorrect Privilege Assignment Affecting ghost package, versions >=2.21.0 <6.56.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.19% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Privilege Assignment vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-GHOST-21693990
  • published24 Oct 2026
  • disclosed1 Oct 2026
  • creditUnknown

Introduced: 1 Oct 2026

NewCVE-2026-103286  (opens in a new tab)
CWE-266  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.56.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Incorrect Privilege Assignment via the notifications system, which lacks proper authorization checks, allowing a low-privilege staff user to escalate to a higher-privilege staff role. An authenticated attacker with staff-level access can exploit this flaw to gain elevated privileges within the application.

References

CVSS Base Scores

version 4.0
version 3.1