Insufficient Session Expiration Affecting ghost package, versions >=6.20.0 <6.57.1


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.27% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Insufficient Session Expiration vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-GHOST-21693996
  • published24 Oct 2026
  • disclosed1 Oct 2026
  • creditUnknown

Introduced: 1 Oct 2026

NewCVE-2026-103283  (opens in a new tab)
CWE-613  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.57.1 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Insufficient Session Expiration via the isVerifiedSession function in session-service.js, where session verification state is not bound to a specific user identity. When a session's verified flag is set without an associated verified_user_id, the check session.verified_user_id === session.user_id resolves to undefined === undefined, evaluating to true and incorrectly granting verified status to any user inheriting that session. An authenticated attacker can exploit this to bypass staff device verification and gain unauthorized access to privileged functionality.

References

CVSS Base Scores

version 4.0
version 3.1