Incorrect Authorization Affecting ghost package, versions >=4.0.0 <6.63.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.38% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-GHOST-21693998
  • published24 Oct 2026
  • disclosed1 Oct 2026
  • creditpptx704, evertrustai, Itamar Peretz, Ethan Wilkins, Pedro Pinho

Introduced: 1 Oct 2026

NewCVE-2026-103271  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.63.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Incorrect Authorization via the content API, which allows unauthenticated visitors to retrieve gated post content without authentication. An attacker can directly query the content API to access restricted posts that are intended to be visible only to paying or authenticated members, bypassing all content access controls.

References

CVSS Base Scores

version 4.0
version 3.1