Access Control Bypass Affecting ghost package, versions <6.0.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.38% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Access Control Bypass vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-GHOST-21694005
  • published24 Oct 2026
  • disclosed11 Aug 2026
  • creditUnknown

Introduced: 11 Aug 2026

CVE-2026-72596  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.0.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Access Control Bypass via the permissible process. An attacker can remove posts belonging to other users by exploiting insufficient authorization checks when deleting posts as an authenticated Author-role user.

References

CVSS Base Scores

version 4.0
version 3.1