Improper Handling of Alternate Encoding Affecting ghost package, versions <6.20.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.23% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-GHOST-21694006
  • published24 Oct 2026
  • disclosed1 Oct 2026
  • creditUnknown

Introduced: 1 Oct 2026

NewCVE-2026-103276  (opens in a new tab)
CWE-173  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.20.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Improper Handling of Alternate Encoding via URL-encoded path traversal in file extension filtering, which allows an unauthenticated attacker to bypass extension validation and read theme templates and metadata. By sending requests with URL-encoded characters, an attacker can circumvent the file extension checks and access sensitive theme files that should be restricted.

References

CVSS Base Scores

version 4.0
version 3.1