Cross-site Request Forgery (CSRF) Affecting ghost package, versions >=5.19.0 <6.57.1


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.1% (1st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Cross-site Request Forgery (CSRF) vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-GHOST-21694008
  • published24 Oct 2026
  • disclosed1 Oct 2026
  • creditUnknown

Introduced: 1 Oct 2026

NewCVE-2026-103285  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.57.1 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) via the post feedback functionality, which automatically submits feedback when an authenticated member navigates to a attacker-controlled URL. An attacker can craft a malicious link to the feedback page that, when visited by a logged-in member, submits feedback on their behalf without their knowledge or consent.

References

CVSS Base Scores

version 4.0
version 3.1