Relative Path Traversal Affecting ghost package, versions >=5.8.0 <6.34.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.27% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Relative Path Traversal vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-GHOST-21694012
  • published24 Oct 2026
  • disclosed1 Oct 2026
  • creditUnknown

Introduced: 1 Oct 2026

NewCVE-2026-103278  (opens in a new tab)
CWE-23  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.34.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Relative Path Traversal via improper input validation in the admin iframe, which allows an attacker with content publishing privileges to craft malicious pages that, when visited by an active staff user, enable full account takeover. The vulnerability permits the attacker to compromise both the confidentiality and integrity of the targeted staff account.

References

CVSS Base Scores

version 4.0
version 3.1