Incorrect Authorization Affecting ghost package, versions >=5.2.0 <6.62.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.3% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-GHOST-21694014
  • published24 Oct 2026
  • disclosed1 Oct 2026
  • creditUnknown

Introduced: 1 Oct 2026

NewCVE-2026-103266  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.62.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Incorrect Authorization via the Stripe Checkout flow, which an unauthenticated remote attacker can abuse to attach a paid subscription to an existing member, modify that member's name, and inject arbitrary content into newsletters sent to that member. Depending on the recipient's email client, the injected content is rendered, resulting in HTML injection or XSS.

References

CVSS Base Scores

version 4.0
version 3.1