Information Exposure Affecting ghost package, versions >=5.42.2 <6.58.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.21% (11th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-GHOST-21694015
  • published24 Oct 2026
  • disclosed1 Oct 2026
  • creditUnknown

Introduced: 1 Oct 2026

NewCVE-2026-103275  (opens in a new tab)
CWE-203  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.58.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Information Exposure via the bulk posts/pages destroy endpoints, where filter parameters passed to bulkDestroy are not validated against restricted Admin API fields before being applied to the underlying database query. An authenticated attacker with low privileges can supply filter expressions referencing restricted fields (such as password) to probe or infer sensitive data through the behavior of bulk delete operations.

CVSS Base Scores

version 4.0
version 3.1