Incorrect Authorization Affecting ghost package, versions >=4.3.0 <6.58.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.26% (16th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-GHOST-21694018
  • published24 Oct 2026
  • disclosed1 Oct 2026
  • creditUnknown

Introduced: 1 Oct 2026

NewCVE-2026-103273  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade ghost to version 6.58.0 or higher.

Overview

ghost is a publishing platform

Affected versions of this package are vulnerable to Incorrect Authorization via staff tokens that bypass post editing restrictions. A lower-privilege staff user can present a staff token to edit posts beyond their assigned privilege level, circumventing the authorization checks that would otherwise enforce role-based editing restrictions.

References

CVSS Base Scores

version 4.0
version 3.1