Command Injection Affecting git-add-remote package, versions *


0.0
medium

Snyk CVSS

    Attack Complexity High
    Confidentiality High

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.86% (82nd percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-GITADDREMOTE-564269
  • published 2 Apr 2020
  • disclosed 2 Apr 2020
  • credit JHU System Security Lab

How to fix?

There is no fixed version for git-add-remote.

Overview

git-add-remote is an API for adding git remotes.

Affected versions of this package are vulnerable to Command Injection. The argument name can be controlled by users without any sanitization.

PoC

var root = require("git-add-remote")();
var payload = "& touch Song";
root(payload,'',function(){});

References