Server-Side Request Forgery (SSRF) Affecting google-translate-api-browser package, versions <4.1.3


0.0
low

Snyk CVSS

    Attack Complexity High

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.05% (14th percentile)
Expand this section
NVD
3.7 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-GOOGLETRANSLATEAPIBROWSER-6085299
  • published 26 Nov 2023
  • disclosed 24 Nov 2023
  • credit PinkDraconian

How to fix?

Upgrade google-translate-api-browser to version 4.1.3 or higher.

Overview

google-translate-api-browser is an A free and unlimited API for Google Translate that works in browser

Affected versions of this package are vulnerable to Server-Side Request Forgery (SSRF) when input to translateOptions is accepted from the end user. An attacker can manipulate the tld field, causing the application to generate unsafe URLs that point to local resources. This is due to the translateOptions.tld field not being properly sanitized before being included in the Google translate URL. An attacker with control over the translateOptions can set the tld to a payload such as @127.0.0.1, which results in the full URL becoming https://translate.google.@127.0.0.1/..., where translate.google. is the username used to connect to localhost. This allows the attacker to send requests within internal networks and the local host. If there is an HTTPS application on the internal network with a vulnerability that can be exploited via a GET call, it could be exploited using this vulnerability.

References