Command Injection Affecting @graphql-tools/git-loader package, versions <6.2.6


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-GRAPHQLTOOLSGITLOADER-1062543
  • published 20 Jan 2021
  • disclosed 19 Jan 2021
  • credit Ron Masas

How to fix?

Upgrade @graphql-tools/git-loader to version 6.2.6 or higher.

Overview

Affected versions of this package are vulnerable to Command Injection. The use of exec and execSync in packages/loaders/git/src/load-git.ts allows arbitrary command injection. As this is a dev tool input is generally controlled by the user that executes the command.