Race Condition Affecting grunt Open this link in a new tab package, versions <1.5.3


0.0
medium
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-GRUNT-2813632

  • published

    11 May 2022

  • disclosed

    11 May 2022

  • credit

    haxatron

How to fix?

Upgrade grunt to version 1.5.3 or higher.

Overview

grunt is a JavaScript task runner.

Affected versions of this package are vulnerable to Race Condition via the file.copy operations. Exploiting this vulnerability leads to arbitrary file writing when an attacker can create a symlink just after deletion of the destination symlink, but right before the symlink is being written.