Arbitrary Code Execution Affecting grunt package, versions <1.3.0



    Attack Complexity High
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.85% (82nd percentile)
Expand this section
7.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-GRUNT-597546
  • published 20 Aug 2020
  • disclosed 7 Aug 2020
  • credit Snyk Security Team

How to fix?

Upgrade grunt to version 1.3.0 or higher.


grunt is a JavaScript task runner.

Affected versions of this package are vulnerable to Arbitrary Code Execution due to the default usage of the function load() instead of its secure replacement safeLoad() of the package js-yaml inside grunt.file.readYAML.