Unparsed Raw Web Content Delivery Affecting hyperterse package, versions >=2.0.0 <2.2.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.19% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-HYPERTERSE-15627443
  • published15 Mar 2026
  • disclosed12 Mar 2026
  • creditUnknown

Introduced: 12 Mar 2026

CVE-2026-31841  (opens in a new tab)
CWE-433  (opens in a new tab)

How to fix?

Upgrade hyperterse to version 2.2.0 or higher.

Overview

hyperterse is an A declarative interface to connect your database to your AI agents

Affected versions of this package are vulnerable to Unparsed Raw Web Content Delivery in the search process. An attacker can gain unauthorized access to raw SQL queries by submitting search requests, potentially exposing sensitive database statements intended to remain internal.

CVSS Base Scores

version 4.0
version 3.1