Cross-site Request Forgery (CSRF) Affecting joplin package, versions <2.3.2


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-JOPLIN-1325537
  • published 22 Aug 2021
  • disclosed 25 Jul 2021
  • credit Laurent Cozic

How to fix?

Upgrade joplin to version 2.3.2 or higher.

Overview

joplin is a note taking and to-do application.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) due to missing CSRF checks in various forms.

References