Cross-site Scripting (XSS) Affecting @joplin/lib package, versions <2.9.1


Severity

Recommended
0.0
high
0
10

CVSS assessment made by Snyk's Security Team

    Threat Intelligence

    EPSS
    0.17% (54th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-JOPLINLIB-2960162
  • published 26 Jul 2022
  • disclosed 26 Jul 2022
  • credit @ly1g3

How to fix?

Upgrade @joplin/lib to version 2.9.1 or higher.

Overview

@joplin/lib is a joplin core library.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) via note titles, due to unescaped user input reaching GotoAnything.tsx. This may lead to Remote Code Execution.

CVSS Scores

version 3.1
Expand this section

Snyk

8.8 high
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    Required
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    High
  • Integrity (I)
    High
  • Availability (A)
    High
Expand this section

NVD

9 critical