Malicious Package Affecting jquery-lh Open this link in a new tab package, versions *


0.0
critical
  • Exploit Maturity

    Mature

  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-JQUERYLH-2931079

  • published

    17 Jun 2022

  • disclosed

    17 Jun 2022

  • credit

    Ax Sharma

Introduced: 17 Jun 2022

New Malicious CWE-506 Open this link in a new tab

How to fix?

Avoid using jquery-lh altogether.

Overview

jquery-lh is a malicious package. The package contains a malicious payload that steals the user's environment information and uploads it to the attacker's server.

References