Cross-site Scripting (XSS) Affecting jquery-ui package, versions <1.13.2



    Attack Complexity Low
    User Interaction Required

    Threat Intelligence

    EPSS 0.22% (60th percentile)
Expand this section
6.1 medium
Expand this section
Red Hat
6.1 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-JQUERYUI-2946728
  • published 17 Jul 2022
  • disclosed 10 Jul 2022
  • credit Elkano

How to fix?

Upgrade jquery-ui to version 1.13.2 or higher.


jquery-ui is a library for manipulating UI elements via jQuery.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) via the initialization of check-box-radio widget on an input tag enclosed within a label, which leads to the parent label contents being considered as the input label.

Exploiting this vulnerability is possible if a .checkboxradio( "refresh" ) call is executed on such a widget, and the initial HTML contains encoded HTML entities, leading them to be erroneously decoded.