Command Injection Affecting lodash-es package, versions <4.17.21


0.0
high

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
    Privileges Required High
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7.2 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-LODASHES-2434284
  • published 15 Feb 2021
  • disclosed 17 Nov 2020
  • credit Marc Hassan

How to fix?

Upgrade lodash-es to version 4.17.21 or higher.

Overview

Affected versions of this package are vulnerable to Command Injection via template.

PoC

var _ = require('lodash');

_.template('', { variable: '){console.log(process.env)}; with(obj' })()