Arbitrary Command Execution Affecting mc-kill-port package, versions *


0.0
high

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-MCKILLPORT-2419070
  • published 18 Jul 2022
  • disclosed 6 Mar 2022
  • credit Feng Xiao, Zhongfu Su

How to fix?

There is no fixed version for mc-kill-port.

Overview

mc-kill-port is a package allowing termination of ports.

Affected versions of this package are vulnerable to Arbitrary Command Execution via the kill function, due to missing sanitization of the port argument.

PoC

const kill = require("mc-kill-port");
kill("abc|echo rce > newFile.txt")

References