Incorrect Authorization Affecting @neo4j/graphql package, versions >=7.0.0 <7.6.4


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.31% (23rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-NEO4JGRAPHQL-21709021
  • published25 Oct 2026
  • disclosed12 Oct 2026
  • creditUnknown

Introduced: 12 Oct 2026

NewCVE-2026-92682  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade @neo4j/graphql to version 7.6.4 or higher.

Overview

@neo4j/graphql is an A GraphQL to Cypher query execution layer for Neo4j and JavaScript GraphQL implementations

Affected versions of this package are vulnerable to Incorrect Authorization via the NONE quantifier in AuthConnectionFilter and AuthRelationshipFilter, which incorrectly behaves like SOME when evaluating authorization rules on relationship and connection filters. Because the NONE operator is not negated before being returned as a Cypher EXISTS predicate, authorization checks that are intended to deny access when any matching relationship exists instead grant access under those same conditions, allowing an attacker to bypass relationship-based authorization rules.

CVSS Base Scores

version 4.0
version 3.1