User Interface (UI) Misrepresentation of Critical Information Affecting next package, versions >=10.0.0 <12.1.0


0.0
medium

Snyk CVSS

    Attack Complexity High
    Integrity High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-NEXT-2405694
  • published 18 Feb 2022
  • disclosed 18 Feb 2022
  • credit Unknown

How to fix?

Upgrade next to version 12.1.0 or higher.

Overview

next is a react framework.

Affected versions of this package are vulnerable to User Interface (UI) Misrepresentation of Critical Information due to improper CSP (content security policy).

Note: In order to be affected ALL of the following must be true:

  1. Next.js between version 10.0.0 and 12.0.10.

  2. The next.config.js file has images.domains array assigned.

  3. The image host assigned in images.domains allows user-provided SVG

Not affected: The next.config.js file has images.loader assigned to something other than "default".