Uncaught Exception Affecting next package, versions >=12.2.3 <12.2.4


0.0
medium

Snyk CVSS

    Attack Complexity High
    Availability High
Expand this section
NVD
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-NEXT-3011410
  • published 31 Aug 2022
  • disclosed 30 Aug 2022
  • credit Unknown

How to fix?

Upgrade next to version 12.2.4 or higher.

Overview

next is a react framework.

Affected versions of this package are vulnerable to Uncaught Exception due to specific requests that can cause an unhandledRejection in the server which can crash the process in specific Node.js versions with strict unhandledRejection handling.

Note: Applications are only vulnerable if they:

  1. are using a Node.js version that is above v15.0.0

  2. are using next start or a custom server

Users are not affected if they are using deployments on Vercel along with similar environments where next-server isn't being shared across requests.