Improper Authentication Affecting next-auth package, versions <4.12.0



    Attack Complexity High
    User Interaction Required
    Confidentiality High
    Integrity High

    Threat Intelligence

    EPSS 0.08% (35th percentile)
Expand this section
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-NEXTAUTH-3035577
  • published 29 Sep 2022
  • disclosed 29 Sep 2022
  • credit voinik

How to fix?

Upgrade next-auth to version 4.12.0 or higher.


next-auth is an Authentication for Next.js

Affected versions of this package are vulnerable to Improper Authentication due to missing validation for both the identifier and the token in the Upstash Redis adapter.