Malicious Package Affecting ng-ui-library package, versions >1.0.986 <1.0.988


0.0
critical

Snyk CVSS

    Exploit Maturity Mature
    Attack Complexity Low
    Scope Changed
    Confidentiality High
    Integrity High
    Availability High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-NGUILIBRARY-449527
  • published 10 Jun 2019
  • disclosed 7 Jun 2019
  • credit npm security

Introduced: 7 Jun 2019

Malicious CVE NOT AVAILABLE CWE-506 Open this link in a new tab

How to fix?

Upgrade ng-ui-library to version 1.0.988 or higher.

Overview

ng-ui-library is a NBS UI library for angular ng6

Affected versions of this package are vulnerable to Malicious Package. The package contains malicious code that when executed in the browser enumerates password, cvc and cardnumber fields from forms and sends the extracted values to https://js-metrics.com/minjs.php?pl=