Malicious Package Affecting ngx-pica package, versions >1.1.4 <1.1.6


0.0
critical

Snyk CVSS

    Exploit Maturity Mature
    Attack Complexity Low
    Scope Changed
    Confidentiality High
    Integrity High
    Availability High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-NGXPICA-449519
  • published 10 Jun 2019
  • disclosed 7 Jun 2019
  • credit npm security

Introduced: 7 Jun 2019

Malicious CVE NOT AVAILABLE CWE-506 Open this link in a new tab

How to fix?

Upgrade ngx-pica to version 1.1.6 or higher.

Overview

ngx-pica is a Angular 5 module to resize images files in browser using pica - high quality image resize in browser.

Affected versions of this package are vulnerable to Malicious Package. The package contains malicious code that when executed in the browser enumerates password, cvc and cardnumber fields from forms and sends the extracted values to https://js-metrics.com/minjs.php?pl=