Improper Verification of Cryptographic Signature Affecting node-forge package, versions <1.3.0


Severity

0.0
medium
0
10

    Threat Intelligence

    EPSS
    0.07% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-NODEFORGE-2430337
  • published 20 Mar 2022
  • disclosed 20 Mar 2022
  • credit Moosa Yahyazadeh

How to fix?

Upgrade node-forge to version 1.3.0 or higher.

Overview

node-forge is a JavaScript implementations of network transports, cryptography, ciphers, PKI, message digests, and various utilities.

Affected versions of this package are vulnerable to Improper Verification of Cryptographic Signature due to RSA's PKCS#1 v1.5 signature verification code which does not properly check DigestInfo for a proper ASN.1 structure. This can lead to successful verification with signatures that contain invalid structures but a valid digest.

References

CVSS Scores

version 3.1
Expand this section

Snyk

5.6 medium
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    High
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    None
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    Low
  • Integrity (I)
    Low
  • Availability (A)
    Low
Expand this section

NVD

5.3 medium
Expand this section

Red Hat

5.3 medium