Arbitrary Code Execution Affecting node-import package, versions *


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.12% (45th percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-NODEIMPORT-571691
  • published 15 Jun 2020
  • disclosed 15 Jun 2020
  • credit JHU System Security Lab

How to fix?

There is no fixed version for node-import.

Overview

node-import is a package that imports dependencies and run it directly or concatenate them and exports to file.

Affected versions of this package are vulnerable to Arbitrary Code Execution. The "params" argument of module function can be controlled by users without any sanitization.b. This is then provided to the “eval” function located in line 79 in the index file "index.js".

PoC

var a = require("node-import");
var params = {
  'fs=require("fs");fs.writeFile("JHU");//':123
}
a.module('',params,true)

References