Command Injection Affecting nodemailer package, versions <6.4.16


0.0
high
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-NODEMAILER-1038834

  • published

    12 Nov 2020

  • disclosed

    11 Nov 2020

  • credit

    Vineet Kumar

How to fix?

Upgrade nodemailer to version 6.4.16 or higher.

Overview

nodemailer is an Easy as cake e-mail sending from your Node.js applications

Affected versions of this package are vulnerable to Command Injection. Use of crafted recipient email addresses may result in arbitrary command flag injection in sendmail transport for sending mails.

PoC

-bi@example.com (-bi Initialize the alias database.)
-d0.1a@example.com (The option -d0.1 prints the version of sendmail and the options it was compiled with.)
-Dfilename@example.com (Debug output ffile)