Use After Free Affecting node-sass package, versions >=4.4.0 <4.13.1


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
3.84% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-NODESASS-535497
  • published25 Nov 2019
  • disclosed26 May 2018
  • creditUnkown

Introduced: 26 May 2018

CVE-2018-11499  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade node-sass to version 4.13.1 or higher.

Overview

node-sass is a Node.js bindings package for libsass.

Affected versions of this package are vulnerable to Use After Free. A use-after-free vulnerability exists in handle_error() in sass_context.cpp in LibSass 3.4.x and 3.5.x through 3.5.4 that could be leveraged to cause a denial of service (application crash) or possibly unspecified other impact. node-sass is affected by this vulnerability due to its usage of libsass.

CVSS Base Scores

version 3.1