Out-of-bounds Read Affecting node-sass package, versions <4.2.0



    Attack Complexity Low
    User Interaction Required
    Availability High

    Threat Intelligence

    EPSS 0.15% (51st percentile)
Expand this section
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-NODESASS-535499
  • published 25 Nov 2019
  • disclosed 24 Jul 2017
  • credit Unknown

How to fix?

Upgrade node-sass to version 4.2.0 or higher.


node-sass is a Node.js bindings package for libsass.

Affected versions of this package are vulnerable to Out-of-bounds Read. ]There is a heap-based buffer over-read in the Sass::Prelexer::re_linebreak function in lexer.cpp in LibSass 3.4.5. A crafted input will lead to a remote denial of service attack.