Incorrect Authorization Affecting nuxt package, versions >=4.6.0 <4.6.3


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.34% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-NUXT-22132587
  • published2 Nov 2026
  • disclosed30 Oct 2026
  • creditGrant Abejar, Nikhil Agrawal, Jun Wei, Shu Takahashi

Introduced: 30 Oct 2026

NewCVE-2026-119200  (opens in a new tab)
CWE-41  (opens in a new tab)
CWE-436  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade nuxt to version 4.6.3 or higher.

Overview

Affected versions of this package are vulnerable to Incorrect Authorization via dot segment handling in toRequestEvent in packages/nitro-server/src/runtime/utils/event.ts. An attacker can send a request containing . or .. path segments (including their percent-encoded forms such as %2e) to cause the server-side router to resolve the path to a different route than the one named by event.path, potentially bypassing server middleware path checks and accessing unintended pages or resources.

Note: Path checks in server middleware should also account for the page router matching paths case-insensitively unless router.options.sensitive is set.

CVSS Base Scores

version 4.0
version 3.1