Incorrect Authorization Affecting openclaw package, versions <2026.7.1


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.23% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-OPENCLAW-21708999
  • published25 Oct 2026
  • disclosed26 Sept 2026
  • creditUnknown

Introduced: 26 Sep 2026

CVE-2026-100578  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade openclaw to version 2026.7.1 or higher.

Overview

openclaw is a 🦞 OpenClaw — Personal AI Assistant

Affected versions of this package are vulnerable to Incorrect Authorization via the chat.send endpoint, which fails to restrict owner-only infrastructure tools (gateway and cron) in Gateway deployments. A write-scoped non-owner caller can start a chat turn whose tool inventory includes these owner-only tools, causing the agent to invoke owner-only configuration or scheduling operations, including persistent state changes. Practical impact depends on the tools selected by the model and the caller's ability to steer the turn.

Note: This is only exploitable in Gateway deployments using authentication modes that honor caller identity and narrower operator scopes. Shared-secret token and password callers are treated as fully trusted operators and are not affected.

Workaround

Restrict chat.send to administrators in identity-bearing deployments and remove gateway and cron from affected agent tool policies.

References

CVSS Base Scores

version 4.0
version 3.1