Incorrect Authorization Affecting openclaw package, versions <2026.7.1


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.32% (23rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-OPENCLAW-21709005
  • published25 Oct 2026
  • disclosed26 Sept 2026
  • creditUnknown

Introduced: 26 Sep 2026

CVE-2026-100589  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade openclaw to version 2026.7.1 or higher.

Overview

openclaw is a 🦞 OpenClaw — Personal AI Assistant

Affected versions of this package are vulnerable to Incorrect Authorization via the browser tool's node target selection, which fails to enforce the allowHostControl=false configuration for sandboxed sessions. An attacker with control over sandboxed agent input can select a paired node and invoke host browser actions, allowing them to inspect or manipulate the connected browser profile and its authenticated state.

Note: This is only exploitable when the browser tool is active and a paired-node target is configured within a sandboxed agent session that has allowHostControl=false set.

References

CVSS Base Scores

version 4.0
version 3.1