Incorrect Authorization Affecting openclaw package, versions <2026.7.1


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.3% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-OPENCLAW-21709011
  • published25 Oct 2026
  • disclosed26 Sept 2026
  • creditUnknown

Introduced: 26 Sep 2026

CVE-2026-100588  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade openclaw to version 2026.7.1 or higher.

Overview

openclaw is a 🦞 OpenClaw — Personal AI Assistant

Affected versions of this package are vulnerable to Incorrect Authorization via node.invoke, which does not enforce the administrator scope requirement on browser control even though direct browser.request access requires administrator scope. In Gateway deployments that honor caller identity and narrower operator scopes, a write-scoped caller with access to a connected browser-capable node can inspect pages, navigate tabs, or interact with browser-visible applications without the configured admin requirement. Practical impact depends on the browser profile and signed-in state.

Note: This is only exploitable in Gateway deployments that honor caller identity and narrower operator scopes; shared-secret token and password callers are considered fully trusted operators and are not affected.

Workaround

Before upgrading, restrict node.invoke to administrators in identity-bearing deployments and disconnect sensitive browser nodes.

References

CVSS Base Scores

version 4.0
version 3.1