Incorrect Authorization Affecting openclaw package, versions <2026.7.1


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.25% (15th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-OPENCLAW-21709013
  • published25 Oct 2026
  • disclosed26 Sept 2026
  • creditUnknown

Introduced: 26 Sep 2026

CVE-2026-100586  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade openclaw to version 2026.7.1 or higher.

Overview

openclaw is a 🦞 OpenClaw — Personal AI Assistant

Affected versions of this package are vulnerable to Incorrect Authorization via missing owner authorization enforcement in the Codex plugin's native binding controls. A non-owner channel sender with command access can create a native Codex conversation binding and execute host-capable turns, gaining access to files, tools, and processes available to the Codex runtime. The practical impact depends on the configured Codex permissions and host environment.

References

CVSS Base Scores

version 4.0
version 3.1