Incorrect Authorization Affecting openclaw package, versions <2026.7.1


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.18% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-OPENCLAW-21709014
  • published25 Oct 2026
  • disclosed26 Sept 2026
  • creditUnknown

Introduced: 26 Sep 2026

CVE-2026-100590  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade openclaw to version 2026.7.1 or higher.

Overview

openclaw is a 🦞 OpenClaw — Personal AI Assistant

Affected versions of this package are vulnerable to Incorrect Authorization via the /voice set command, which fails to enforce owner or administrator authority for external-channel senders. A non-owner user with command access can invoke /voice set to persistently change the Gateway's configured Talk voice for the provider, affecting configuration integrity and future voice output without exposing credentials or granting additional host capabilities.

References

CVSS Base Scores

version 4.0
version 3.1